Exlorist 600 won't communicate with PC

Ask questions about GPS Magellan equipment here.

Exlorist 600 won't communicate with PC

Postby Shack » Mon Jul 23, 2007 4:25 pm

Hi all I just bought a explorist 600. I'm new to gps and I wanted something for geocaching. My question is,when I try to use the usb file transfer my computer doesn't seem to recognise the unit. When you first plug in the usb cable it shows a new device and that it is working properly but the 600 doesn't see the computer and when I go to device manager the only entry is under universal serial bus controllers as an unknown device. This I believe is telling me that the drivers aren't loading. I've uninstalled and reinstalled unattached and reattached with the same results. I know it should show it as a usb storage but no go. anyone else have this problem or am I the only one. Any help would be appreciated Shack
Shack
 

Re: Exlorist 600 won't communicate with PC

Postby nsew45 » Wed Jul 25, 2007 3:27 pm

According to the manual:

1. Turn the eXplorist off.
2. First connect the PC interface cable to the connector on the back of the eXplorist.
3. Insert the USB connector on the PC interface cable to any of the USB ports on a personal computer.
4. Turn the eXplorist on. 5. You may get a message on your computer that a new USB device has been found.
6. If connected properly, the eXplorist will display the USB File Transfer screen, indicating that the eXplorist is in the file transfer mode.

If it isn't in the file transfer mode:
1. Press the "Menu" key.
2. Select Advanced Features
3. Select Communication
4. Select File Transfer


I don't see anything on the GPS to indicate it is successfully connected to the PC. However, the PC, when looking at the Windows Explorer (File Manager) will show a new drive. Also if you go to the Device Manager, look under Modems and it should show the Magellan. It won't show under com ports.
nsew45
 

Re: Exlorist 600 won't communicate with PC

Postby Shack » Wed Jul 25, 2007 6:49 pm

I believe i've figured out the problem. I don't have an ac adapter( I have one ordered thru magellan but hasn't got here yet) so i've been trying it using only the power from the usb port and it won't even go into file transfer mode. I do have an adapter for the cars cigarette lighter and today while geocaching I plugged it in and turned on the unit and it went right into file transfer mode. Sooooo I'm assuming that the usb power is for charging the battery only. Thanks Shack
Shack
 

Re: Exlorist 600 won't communicate with PC

Postby nsew45 » Thu Jul 26, 2007 1:18 pm

Shack, I use mine all the time with just the usb cable plugged into the laptop. I also have a cigarette lighter/power source to USB adapter for the car. It works fine without the optional AC adapter. I assume you are using Windows XP? Make sure you have Show Hidden Files checked and Hide protected system files unchecked in the Windows Explorer Tools Folder Options. With your eXplorist in File Transfer Mode you won't see the PC from the GPS unit. Everything is done from the PC. When you connect the GPS and start it, the GPS should come up in the communication menu. If you select file transfer mode, you should get a Windows Explorer (file manager) window open on the computer showing the file folders on your GPS as a new drive.
nsew45
 

Re: Exlorist 600 won't communicate with PC

Postby Troy » Fri Jul 27, 2007 2:00 am

nsew45...After the window opens on the PC with the file folders what do you do next? I am having connection problems also.. I am fixing to make a new thread for my 500LE. Thanks Troy
Troy
 


Return to Magellan

Who is online

Users browsing this forum: No registered users and 0 guests

cron